Resolved
The issue affecting users and account admins while switching between sub-accounts (locations) has been resolved.We will continue to monitor the system to ensure stability.
Posted .
Created
We are investigating an issue impacting some users and account admins who may be unable to switch between sub-accounts (locations). Our team is actively working on a fix and will provide updates as more information becomes available.
Posted .
Resolved