Back
Resolved

Form Service Disruption

Started , resolved .

Forms
Resolved

The issue has been resolved, and the affected service is operating normally again. Our team has verified that forms are accessible and functioning as expected.

Posted .
Created

We are currently investigating an issue affecting our Form service. Small subset of users may encounter issue when attempting to access certain forms.

Posted .