Back
Resolved
Resolved
Some agencies and sub-accounts are intermittently unable to save or load email builder templates and schedule email campaigns due to GCS outage
Started , resolved .
Emails
Resolved
GCS issue is resolved and our services are back to normal
Posted .
Created
we are working on it and will get back to you shortly with updates
Posted .