Back
Resolved
Resolved
SmartLists page Loading issue
Started 3 Jun at 10:05am CDT, resolved 3 Jun at 10:50am CDT.
Contacts
Opportunities
Resolved
Services are back to normal. Smart Lists should now load successfully
Posted 3 Jun at 10:50am CDT.
Created
We’re having some trouble with SmartLists Page. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted 3 Jun at 10:05am CDT.