Back
Resolved

Form and Survey Analytics Loading Issues Due to AWS Outage

Started 7 May at 07:00pm CDT, resolved 8 May at 02:25am CDT.

Forms Analytics Surveys
Resolved

The issue with form and survey analytics not loading has been resolved. Analytics data is now loading correctly.

Posted 8 May at 02:25am CDT.
Created

We are currently experiencing issues with form and survey analytics not loading correctly, resulting in no data being displayed for some users.
This issue is related to an ongoing AWS outage impacting dependent services. We are actively monitoring the situation and working to restore functionality as soon as possible.

Posted 7 May at 07:00pm CDT.