Back
Resolved
Resolved
Website/Funnel Builder issues
Started 13 Aug at 12:35pm CDT, resolved 13 Aug at 12:58pm CDT.
Funnels & Websites
Resolved
The devs have investigated this, and issues with Funnel/website builder should be resolved. Please contact support if you are still having issues.
Posted 13 Aug at 12:58pm CDT.
Created
We are currently investigating an issue with our Funnel/website builder not opening.
Posted 13 Aug at 12:35pm CDT.