Back
Resolved
Resolved
Surveys Submission issues
Started 14 Aug at 11:15am CDT, resolved 14 Aug at 11:55am CDT.
Surveys
Resolved
This issue is now resolved. Survey submissions are now fully operational.
Posted 14 Aug at 11:55am CDT.
Created
We identified an issue with some surveys being unable to submit. The team has identified the root cause and is working on a fix.
This issue is only impacting a few surveys and not all surveys are impacted.
Posted 14 Aug at 11:15am CDT.