Back
Resolved

Facebook Lead Ads Outage

Started 24 Oct at 12:00pm CDT, resolved 28 Oct at 02:05am CDT.

Integrations
Resolved

We have resolved the issue.

Posted 28 Oct at 02:05am CDT.
Created

We are currently experiencing an issue with Facebook Lead Ads not passing through. Our team is actively investigating and working to resolve this. Updates will be posted as soon as available.

Posted 24 Oct at 12:00pm CDT.