Back
Resolved

Issue with Calendar Performance

Started 29 Oct at 08:37am CDT, resolved 29 Oct at 09:01am CDT.

Calendars
Resolved

The issues affecting calendar performance and appointment bookings have been resolved. Thank you for your patience.

Posted 29 Oct at 09:01am CDT.
Created

We’re aware of ongoing issues affecting calendar performance and appointment bookings. Our team is actively working on a resolution. Thank you for your patience.

Posted 29 Oct at 08:37am CDT.