Back
Resolved

Funnel Page builder issue

Started 17 Nov at 06:05pm CST, resolved 18 Nov at 06:35pm CST.

Funnels & Websites
Resolved

Issue resolved.

Posted 18 Nov at 06:35pm CST.
Updated

A fix is deployed. Validating with customers who faced the issue

Posted 17 Nov at 06:35pm CST.
Created

Some users are facing intermittent issue with funnel page builder.
We are working on this.
 
Workaround (until a fixed): Connecting via VPN will not face the issue.

Posted 17 Nov at 06:05pm CST.