Back
Resolved

Calendars pages degraded performance

Started 12 Feb at 08:40am CST, resolved 12 Feb at 09:00am CST.

Calendars
Resolved

The system is back to normal

Posted 12 Feb at 09:00am CST.
Created

We noticed slowness in calendars pages and team is working on it.
All the external facing pages (Booking, free slots, etc) are good.

Posted 12 Feb at 08:40am CST.