Back
Resolved

Workflow Trigger Delays

Started 28 Mar at 08:30pm CDT, resolved 29 Mar at 12:25am CDT.

Workflows
Resolved

The issue is resolved.

Posted 29 Mar at 12:25am CDT.
Created

We are currently investigating delays affecting specific workflow triggers, including Contact Created, Contact Tags, and other CRM-related events. Our engineering team is working to identify the root cause and restore normal processing. We will provide updates as more information becomes available.

Posted 28 Mar at 08:30pm CDT.