Resolved
Forms issues should now be Resolved! If you are still having issues please try refreshing your browser or clearing cache. If you are still having issues please reach out to support.
Posted 3 Apr at 12:35pm CDT.
Created
We are investigating reports of and outage with our Forms Feature. Please stay tuned for more updates.
Posted 3 Apr at 12:00pm CDT.
Resolved