Back
Resolved

Degraded Voice call

Started 22 Apr at 01:45am CDT, last updated 22 Apr at 02:00am CDT.

LC Phone
Updated

The issue is resolved

Posted 22 Apr at 02:00am CDT.
Resolved

The issue is resolved

Posted 22 Apr at 02:00am CDT.
Created

Drop in quality of voice calls. Some calls failing

Posted 22 Apr at 01:45am CDT.