Back
Resolved

GCP & Cloudflare Outage

Started 12 Jun at 01:30pm CDT, resolved 12 Jun at 05:00pm CDT.

gohighlevel.com app.gohighlevel.com
Resolved

Core systems are now back online following the major outage impacting Google Cloud and Cloudflare services. Our team has resolved the critical issues, and functionality has been restored across the platform.

Posted 12 Jun at 05:00pm CDT.
Updated

Update 4:45pm CST

Core systems are back online! We are still cleaning up some edge cases and issues from the outages.

We will have another update on impacts from this outage soon.

Posted 12 Jun at 04:00pm CDT.
Created

At approximately 1:30 PM, Google Cloud experienced a global outage that impacted multiple platforms and services, including HighLevel.

Our development team immediately began investigating the issue and reached out to our points of contact at both Cloudflare and Google for updates.

As of around 3:00 PM, systems have slowly started to come back online.

The team is actively assessing the impact on triggers, automations, integrations, incoming leads, and conversations.

We will share another update as soon as more information becomes available.

You can also learn more about the google cloud outage here.

https://www.tomsguide.com/news/live/google-cloud-down-jun-12-outage?fbclid=IwY2xjawK4FLNleHRuA2FlbQIxMQBicmlkETFESWF0WGVMd1NVOTNkelB0AR6GvCUvSqFRd9wBFvnyCJz5JJWTGfVPZ4evLOBTjqMmoVpTcHC7sLHmjpF7GQ_aem_NivJYoocWj7HT5Ju-1FKKw

https://www.cnbc.com/2025/06/12/google-cloud-and-other-internet-services-are-reporting-outages.html

Posted 12 Jun at 01:30pm CDT.