Back
Resolved

Opportunities are not loading for some locations and performance is slow.

Started 25 Sep at 11:30pm CDT, resolved 26 Sep at 05:50am CDT.

Opportunities
Resolved

Opportunities are now loading fine, the service has been restored, and the issue is resolved.

Posted 26 Sep at 05:50am CDT.
Created

Opportunities are not loading for some locations, and performance is slow. The team is currently investigating the issue.

Posted 25 Sep at 11:30pm CDT.