Back
Resolved
Resolved
Issues with chat support
Started 20 Oct at 01:00pm CDT, resolved 20 Oct at 03:10pm CDT.
Chat Widget
Resolved
The issue is resolved.
Posted 20 Oct at 03:10pm CDT.
Created
Our chat support is currently down due to a third-party outage. We’ll share updates as soon as service is restored.
Posted 20 Oct at 01:00pm CDT.