Back
Resolved

Reports of slowness

Started 30 Oct at 08:10am CDT, last updated 30 Oct at 11:30am CDT.

app.gohighlevel.com
Updated

The issue has been resolved.

Posted 30 Oct at 11:30am CDT.
Resolved

The issue has been resolved.

Posted 30 Oct at 11:30am CDT.
Created

We’ve received reports of slowness, and our team is currently working to resolve the issue.

Posted 30 Oct at 08:10am CDT.