Back
Resolved
Resolved
Phone number purchase not working
Started 4 Feb at 12:25pm CST, resolved 4 Feb at 01:08pm CST.
LC Phone
Resolved
The issue has been fully resolved, and all functionality has been restored. The incident was caused by an issue with one of our third-party vendors, which has now been addressed.
Posted 4 Feb at 01:08pm CST.
Created
We have identified some partial issues with the first purchase of phone numbers.
Team is running this down.
Posted 4 Feb at 12:25pm CST.