Back
Resolved
Resolved
Slowness in the calendar, opportunities, contacts.
Started , resolved .
Contacts
Calendars
Opportunities
Resolved
The issue affecting Opportunities, Contacts, Calendar, and Conversations has been resolved. All affected modules are now functioning normally. We have confirmed that the system is operating as expected and will continue to monitor for any further issues.
Posted .
Updated
Contacts and Opportunities are now working as expected. We are continuing to monitor the system. We’ll provide another update as soon as we have further information.
Posted .
Created
We’re investigating an issue affecting calendar, opportunities, contacts and several related features. Our team is actively investigating the issue and working to restore normal functionality. We’ll provide another update as soon as we have more information.
Posted .