Back
Resolved

Delay snapshots loading into sub-accounts

Started , resolved .

Snapshots
Resolved

Systems are restored to normal. Snapshots should load fine now in sub-accounts

Posted .
Created

We are currently seeing delays when loading snapshots into sub-accounts. Users may experience longer than usual processing times when applying a snapshot. Our team is actively investigating the issue. Existing sub-account data is not affected. We will share an update shortly

Posted .